What web browsers do you support?

FoxyLearning will run on most modern web browsers. No other extensions, plugins, or apps are required to view our content or work through our modules. A great site for checking if your browser is up-to-date is  BrowserUpdate.org. You can check if your browser and device meets the basic requirements of our site below:

If you need help figuring out how to update your browser or enable javascript and cookies, check out these guides. Please note that Internet Explorer is not recommended or supported. It is a very old browser, with the last version being released in 2013 (making it practically ancient in internet time!), and does not support modern web technologies very well.

If you are experiencing a problem with our site on your browser, let us know and we'll take a look to see if it is something we can fix.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us